[solving] #error Caffe2 requires Eigen to be at least 3.3.0

caffe2 는 eigen 버전을 3.3.0 이상을 요구한다 그러나 설치된 버젼이 이보다 낮은 버젼이라서 설치가 되지않았다. 아래와 같은 방법으로 해결하자. 1.현재 eigen 버젼을 확인 아마도 3.3.0 이하일 것이다. cat /usr/include/eigen3/Eigen/src/Core/util/Macros.h | grep VERSION 2.아래의 링크에서 최신버젼을 다운 받는다. http://eigen.tuxfamily.org/index.php?title=Main_Page 3.기존 eigen을 제거한후 다운받은 것으로 교환한다. cd /usr/include sudo rm -rf eigen3/ sudo mv path/of/eigen3 /usr/include/ 4.확인 cat…

더 보기